Resolved
The incident has been resolved. A new version of the browser extension has been published on Chrome & Edge. Firefox is not affected.
Identified
Our engineering team has identified the root cause of the incident and they are working on a fix.
The issue appeared after the v5.10 release. This issue can occur when sorting the grid by URL in the password workspace, which results in resources not being displayed in the grid after a page refresh (or logout/login).
Workaround:
If this happens, users can restore the display of resources by:
Clicking on Columns
Selecting Reset columns
This will make the resources visible again.
Identified
Summary:
The issue has now been successfully reproduced and appears to occur when sorting the grid by URL in the password workspace, which results in resources not being displayed in the grid.
A temporary workaround exists by resetting the columns configuration.
The team is currently working on a hotfix.
Investigating
Our engineering team is currently investigating the issue and will provide updates as soon as possible.
Investigating
Our engineering team is currently investigating the issue and will provide updates as soon as possible.
Investigating
Following the release of browser extension v5.10, which introduced React 18 and a significant rework of the resource workspace context, multiple users are unable to view resources in the Bext WebApp (Edge Browser, maybe more). Resources remain accessible via the Bext QuickApp and Mobile Apps.
Impact: High. Multiple users are affected and unable to access resources through the Bext WebApp.
Likely trigger: The issue appeared after the v5.10 release. Two notable changes shipped in this version: an upgrade to React 18 and a significant rework of the resource workspace context. Either or both of these changes are suspected to be related to the regression.
Root cause: Unknown, under investigation.
Steps to resolve: Unknown, under investigation.
Next steps: Try to reproduce the issue in a controlled environment. Determine whether the regression is tied to the React 18 upgrade, the workspace context rework, or an interaction between the two. Identify affected user segments and the full scope of impact. Define a fix or workaround.